Publicidad

17 mayo 2013

Instalar controladores Intel en linux con el instalador de Intel


Realizando una instalación limpia de Fedora 18 me encontré con la noticia de que Intel ha liberado controladores para los usuarios de linux que usan sus tarjetas gráficas. En 01.org/linuxgraphics/ es en dónde pueden encontrarlo, hay paquetes para Ubuntu, Fedora y el código fuente para las otras distribuciones.

Para instalarlo solo deben ingresar al siguiente enlace 01.org/linuxgraphics/downloads ahí eligen "Intel Linux Graphics Installer" en el momento de escribir esta entrada la versión mas reciente es la versión 1.0 publicada el 27 de Mayo del 2013 y los dispositivos soportados son:
  • Ivy Bridge HD Graphics 4000 (Core i7 3610QM, Core i7 3770K)
  • Ivy Bridge HD Graphics 2500 (Core i5 3550)
  • Sandy Bridge HD Graphics 3000 (Core i7 2720QM, Core i7 2630QM, Core i7 2600K, Core i5 2500K)
  • Sandy Bridge HD Graphics 2000 (Core i7 2400S)
  • Intel® HD Graphics (Core i5 670, Core i5 520M)
  • GMA 3150 (Atom N450)
  • GM45
  • GM965
  • Q965
  • 945GM
Primero descargan el archivo dependiendo del SO que tengan y la versión, luego de eso ejecutan en la terminal el siguiente comando.

En Ubuntu:
wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | \sudo apt-key add -

En Fedora:
wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 ; \ sudo rpm --import RPM-GPG-KEY-ilg-2

Luego ejecutan el archivo que han descargado, una vez instalado como usuario root ejecutan el programa escribiendo en la consola:

intel-linux-graphics-installer

Les aparecerá lo siguiente:


Solo deben seguir las indicaciones del programa el cual actualizará el sistema y agregará un repositorio de intel para recibir las actualizaciones, si por algún motivo no se completa la instalación intenten ejecutar el programa otra vez, en lo personal lo tuve que ejecutar 4 veces para que instalara todo y no me mostrara ningún error.

Problemas conocidos:(traducción del sitio de descarga si existe algún error se aceptan correcciones :D)
  • Para los usuarios de ubutnu que tengan paquetes de 32 y 64 bits el instalador no los actualiza como debería, debido a un problema con el sistema utilizado para generar los paquetes que hospedan en 01.org, según indican ya están trabajando en una solución, además de recalcar que no debe forzarse el proceso de actualización del sistema por medio del programa por que podría estropear el sistema.
  • Los usuarios que usen un proxy transparente han reportado que no pueden instalar los controladores por medio de este programa.
  • Ubuntu kernel linux-LowLatency no es compatible con esta instalación. El programa de instalación ha sido validado para su uso con el kernel de Ubuntu linux-generic.
Si les surge algún problema pueden pedir ayuda en el foro 01.org/linuxgraphics/forums/general-discussion

No hay comentarios.:

Publicar un comentario

Publicidad

Publicidad